Author Topic: Uploading to Youtube, Can only hear one sound channel.  (Read 2147 times)

paperboy

  • Noob
  • *
  • Posts: 2
Uploading to Youtube, Can only hear one sound channel.
« on: May 08, 2014, 07:29:06 am »
Recently I've tried to upload my video to YouTube. When I uploaded I could only hear myself. I couldn't hear my Skype or My Game. Only one sound channel is working when I upload. Please help me.

Thanks,
 ~ 8) PB

RobiePAX

  • Monster
  • ****
  • Posts: 274
Re: Uploading to Youtube, Can only hear one sound channel.
« Reply #1 on: May 08, 2014, 07:57:45 am »
Don't worry, it's a common mistake by newbies. YouTube just like a video player can't play all audio tracks at the same time, so it plays only the primary default one. Otherwise imagine the disaster if you would watch Director's Cut DVD Movies where there's original movie audio track, directors commentary tracks, multiple languages tracks, etc and they all would play at the same time.

You must extract audio tracks first(simply right-click on the video file and click extra audio streams) and then combine them in a video editor(simply put secondary audio track(s) right under the primary one) and re-encode your video. Sony Movie Studio does it automatically, for Adobe Premiere Elements you need to extract audio first. In theory you can do it on a free Windows Movie Maker too, not that I tried though, I tend to stay away from WMM to keep my brain cells healthy.

Not really sure why you asked your question in the Off Topic section, since your question is legitimately valid to be in the Dxtory Support section.
« Last Edit: May 08, 2014, 07:59:01 am by RobiePAX »

paperboy

  • Noob
  • *
  • Posts: 2
Re: Uploading to Youtube, Can only hear one sound channel.
« Reply #2 on: May 08, 2014, 09:44:36 am »
Thank you. ;D

8) PB