ExKode Forum

Dxtory => Help & Support => Topic started by: Selgald on October 03, 2013, 03:18:36 am

Title: Problems with Battlefield 4
Post by: Selgald on October 03, 2013, 03:18:36 am
Hi,

when I start Battlefield 4 and then dxtory, dxtory dont recognize that BF4 is running.
when I start dxtory then Battlefield 4 the first time, Battlefield 4 gets stuck in a black screen
when I start Battlefield 4 close it, start dxtory, start Battlefield 4 again, dxtory and battlefield 4 works fine.

Error Log with BF4:

========== 2013/10/01 11:13:47 ==========
PID:1372     E:\Origin\Battlefield 4 Beta\bf4.exe (x64)
PID:1372     TID:3784     TickCount: 1641161 HU_SetHookCode Fail CalcCodeSegment
PID:1372     TID:3784     TickCount: 1641161 Fail HOOK_CODE IDXGISwapChain_Present HookDXGI.cpp(31)
PID:1372     TID:3784     TickCount: 1641161 dxgi.dll 176888
PID:1372     TID:3784     TickCount: 1641161 E9 13 E1 64 FD 41 56 48 8D 6C 24 C9 48 81 EC B0

========== 2013/10/01 12:54:57 ==========
PID:5960     E:\Origin\Battlefield 4 Beta\bf4.exe (x64)
PID:5960     TID:2764     TickCount: 7711176 HU_SetHookCode Fail CalcCodeSegment
PID:5960     TID:2764     TickCount: 7711176 Fail HOOK_CODE IDXGISwapChain_Present HookDXGI.cpp(31)
PID:5960     TID:2764     TickCount: 7711176 dxgi.dll 176888
PID:5960     TID:2764     TickCount: 7711176 E9 13 E1 C3 04 41 56 48 8D 6C 24 C9 48 81 EC B0

========== 2013/10/01 15:24:33 ==========
PID:6636     E:\Origin\Battlefield 4 Beta\bf4.exe (x64)
PID:6636     TID:5972     TickCount:16687333 HU_SetHookCode Fail CalcCodeSegment
PID:6636     TID:5972     TickCount:16687333 Fail HOOK_CODE IDXGISwapChain_Present HookDXGI.cpp(31)
PID:6636     TID:5972     TickCount:16687333 dxgi.dll 176888
PID:6636     TID:5972     TickCount:16687333 E9 13 E1 42 04 41 56 48 8D 6C 24 C9 48 81 EC B0
Title: Re: Problems with Battlefield 4
Post by: ExKoder on October 03, 2013, 11:10:35 am
It seems that it is the cause of a hook of other programs, or overlay of Origin is the cause.
Title: Re: Problems with Battlefield 4
Post by: Selgald on October 03, 2013, 10:39:02 pm
Turing off the Origin overlay fixed the problem (also that stupid ingame messages that someone joined a server are gone)