Author Topic: Help needed - 1440p 60fps  (Read 8473 times)

De-M-oN

  • Veteran
  • ***
  • Posts: 166
Re: Help needed - 1440p 60fps
« Reply #15 on: October 01, 2015, 07:35:05 pm »
Quote
Yes. You are trying to push your pc more than it can do with dxtory. Shadowplay uses your gpu for the h.264 encoding and trys to strain parts of the gpu that are not used as much during games. Programs like fraps and dxtory and cpu intensive.

No they arent, and NO the speed gain comes NOT by using GPU Encoding, the real cause for this is this:

http://forums.guru3d.com/showpost.php?p=4687310&postcount=61
http://forums.guru3d.com/showpost.php?p=4983364&postcount=5

2560x1440 @ 60fps needs very good HDD writing speed though.

Try MagicYUV with compression method set to predict left instead of dynamic and set the threads to 3 or 4.
Use YUV 4:2:0 as the conversion mode (colorspace).
« Last Edit: October 01, 2015, 07:35:55 pm by De-M-oN »

Nikko

  • Noob
  • *
  • Posts: 11
Re: Help needed - 1440p 60fps
« Reply #16 on: October 02, 2015, 12:00:06 am »
Quote
Yes. You are trying to push your pc more than it can do with dxtory. Shadowplay uses your gpu for the h.264 encoding and trys to strain parts of the gpu that are not used as much during games. Programs like fraps and dxtory and cpu intensive.

No they arent, and NO the speed gain comes NOT by using GPU Encoding, the real cause for this is this:

http://forums.guru3d.com/showpost.php?p=4687310&postcount=61
http://forums.guru3d.com/showpost.php?p=4983364&postcount=5

2560x1440 @ 60fps needs very good HDD writing speed though.

Try MagicYUV with compression method set to predict left instead of dynamic and set the threads to 3 or 4.
Use YUV 4:2:0 as the conversion mode (colorspace).

I've tried again with MahicYUV and am now getting 60fps!!

It was a bit stuttery though, I'm not sure if that was the game that was causing it or something else and need to test further.

Am I selecting 4:2:0 in both drop down boxes?

Also how come 'predict left'? It doesn't recommend it according to the tip box that comes up when I hover over it.

Also the number of cores is the number my cpu has or is that how many cores I am telling it to use? There is already an option in Dxtory for telling it which cores to use and I've been experimenting with forcing it to use core 3 and 4 since the game tends to use 1 and 2 more....is that the right thing to do?

De-M-oN

  • Veteran
  • ***
  • Posts: 166
Re: Help needed - 1440p 60fps
« Reply #17 on: October 02, 2015, 12:38:36 am »
Quote
Am I selecting 4:2:0 in both drop down boxes?

No just conversion. If you dont accept RGB you wouldnt be able to record, because your computer runs of course in RGB.

Quote
Also how come 'predict left'? It doesn't recommend it according to the tip box that comes up when I hover over it.

To reduce cpu load - because dxtory has to hook the engine it helps out a bit. But HDD files will get slightly bigger. Test out, which works better for you.
Another try would be UTVideo, less compression, and so more HDD dependent, therefore less cpu load. Try 4:2:0 bt.709 and 4:2:2 bt.709. Sometimes 4:2:2 is faster with this codec, but increases HDD load further.

Quote
Also the number of cores is the number my cpu has or is that how many cores I am telling it to use? There is already an option in Dxtory for telling it which cores to use and I've been experimenting with forcing it to use core 3 and 4 since the game tends to use 1 and 2 more....is that the right thing to do?

It tells the amount of threads. If you choose 4. It uses 4 threads. It is spreaded to 4 cores then if available. If you have 4 cores and 4 Hyperthreading I would use 3 to 4 cores only, because the game wants some cpu too.

Quote
I've tried again with MahicYUV and am now getting 60fps!!

It was a bit stuttery though

To be honest: With High Framerates I personally gain better performance with MSI Afterburner.

Quote from: DrunkMonk74
But the second one is from a map which has alot of dust particles, trees, sky with clouds etc, and you'll see that at regular intervals the video goes blocky. So if anyone knows of a way I can fix that, or has any ideas I would also appreciate the help.

the first and most important solution:Encourage youtube to encode better

2nd solution:

Use 50 fps instead of 60 (still smooth) and you get a bit more out of it, because less frames need to be served with bitrate.
2048x1152 instead of 2560x1440 would help a lot. It replaces then at the player the 1080p label and the 2048x1152 runs then on the 1080p label, with the bitrate of the 1440p label.
« Last Edit: October 02, 2015, 12:47:19 am by De-M-oN »

Nikko

  • Noob
  • *
  • Posts: 11
Re: Help needed - 1440p 60fps
« Reply #18 on: October 02, 2015, 01:28:46 am »
Quote
Am I selecting 4:2:0 in both drop down boxes?

No just conversion. If you dont accept RGB you wouldnt be able to record, because your computer runs of course in RGB.

Quote
Also how come 'predict left'? It doesn't recommend it according to the tip box that comes up when I hover over it.

To reduce cpu load - because dxtory has to hook the engine it helps out a bit. But HDD files will get slightly bigger. Test out, which works better for you.
Another try would be UTVideo, less compression, and so more HDD dependent, therefore less cpu load. Try 4:2:0 bt.709 and 4:2:2 bt.709. Sometimes 4:2:2 is faster with this codec, but increases HDD load further.

Quote
Also the number of cores is the number my cpu has or is that how many cores I am telling it to use? There is already an option in Dxtory for telling it which cores to use and I've been experimenting with forcing it to use core 3 and 4 since the game tends to use 1 and 2 more....is that the right thing to do?

It tells the amount of threads. If you choose 4. It uses 4 threads. It is spreaded to 4 cores then if available. If you have 4 cores and 4 Hyperthreading I would use 3 to 4 cores only, because the game wants some cpu too.

Quote
I've tried again with MahicYUV and am now getting 60fps!!

It was a bit stuttery though

To be honest: With High Framerates I personally gain better performance with MSI Afterburner.

Quote from: DrunkMonk74
But the second one is from a map which has alot of dust particles, trees, sky with clouds etc, and you'll see that at regular intervals the video goes blocky. So if anyone knows of a way I can fix that, or has any ideas I would also appreciate the help.

the first and most important solution:Encourage youtube to encode better

2nd solution:

Use 50 fps instead of 60 (still smooth) and you get a bit more out of it, because less frames need to be served with bitrate.
2048x1152 instead of 2560x1440 would help a lot. It replaces then at the player the 1080p label and the 2048x1152 runs then on the 1080p label, with the bitrate of the 1440p label.

Thanks for the info it is really appreciated!

I will test again, I'm so glad I can get this working shadowplay looks horrible to what I was producing before.

DrunkMonk74

  • Noob
  • *
  • Posts: 39
Re: Help needed - 1440p 60fps
« Reply #19 on: October 02, 2015, 06:31:46 am »
Quote from: DrunkMonk74
But the second one is from a map which has alot of dust particles, trees, sky with clouds etc, and you'll see that at regular intervals the video goes blocky. So if anyone knows of a way I can fix that, or has any ideas I would also appreciate the help.

the first and most important solution:Encourage youtube to encode better

2nd solution:

Use 50 fps instead of 60 (still smooth) and you get a bit more out of it, because less frames need to be served with bitrate.
2048x1152 instead of 2560x1440 would help a lot. It replaces then at the player the 1080p label and the 2048x1152 runs then on the 1080p label, with the bitrate of the 1440p label.

Thanks for the tip, I'll look into it and see how it goes.

I have found that rolling back Dxtory to version 2.0.128 has helped with recording. Seems to cause less lag in game. Also if I was recording at 1440p60fps, even with MagicYUV and using YUV4:4:4 it was still dropping frames. If I enbale "wait for available buffer" in Dxtory's Advanced Settings, then with version 2.0.128 I'm able to record at 1440p60fps with no frame drops in the recording.

I've tried all the versions of Dxtory since 2.0.128 and none seem to offer the same level of quality and little impact to in game FPS as 2.0.128. So I would recommend rolling back to that version until a more suitable version is released.
i7-5960X @ 4.2GHz; Asus X99-Deluxe; 64Gb DDR4 HyperX Fury @ 2133MHz; 256Gb Samsung 850 Pro; EVGA Titan X SC; Asus PG279Q; NZXT Kraken X61; Corsair AX1200i; Phanteks Enthoo Luxe; SteelSeries Arctis Pro Wireless; Logitech G13; Logitech G900; Windows 10 x64

Nikko

  • Noob
  • *
  • Posts: 11
Re: Help needed - 1440p 60fps
« Reply #20 on: October 02, 2015, 09:47:20 pm »

It tells the amount of threads. If you choose 4. It uses 4 threads. It is spreaded to 4 cores then if available. If you have 4 cores and 4 Hyperthreading I would use 3 to 4 cores only, because the game wants some cpu too.



Quick question, since I use an i5 with only 4 cores and no hyper-threading how many cores should I select in that option?

De-M-oN

  • Veteran
  • ***
  • Posts: 166
Re: Help needed - 1440p 60fps
« Reply #21 on: October 03, 2015, 04:36:47 am »
Try out what works best for you. It can also depend on how cpu intense the game is. Try with 2 or 3, on a less intense game even 4 may work or even work better. Just try out which gives you the best performance.