Author Topic: Adobe Choking on conforming audio, Need solution  (Read 3161 times)

ORCACommander

  • Noob
  • *
  • Posts: 7
Adobe Choking on conforming audio, Need solution
« on: April 29, 2016, 09:48:09 am »
So my general problem is I use lagarith for a codec and generally can record up to 30 minutes or more of footage before editing it. Unfortunately this can Cause adobe CS 6 to choke and die on conforming the embedded audio track 1 of the avi files. however it can handle the same audio tracks just fine if they are a separate file.

PC Specs so hardware is not an issue: http://pcpartpicker.com/b/QKtJ7P

So the solutions I can think of Are:
  • Get DXtory to split the recording into more digestible chunks without resorting to FAT32 file system
  • Get DXtory to output the audio to separate files during recording
  • Extract and delete source audio tracks from the AVI files without transcoding the video
  • 3rd party audio program to do the second bullet

The third bullet is the most likely solution but i can't seem to find something that won't also do a transcode However the second bullet would be more preferable
« Last Edit: April 29, 2016, 09:51:15 am by ORCACommander »

Malix

  • Monster
  • ****
  • Posts: 402
    • Youtube channel
Re: Adobe Choking on conforming audio, Need solution
« Reply #1 on: April 29, 2016, 04:23:43 pm »
I would really like some kind of automatic splitting as well, either by time or filesize, either would be fine by me.

Though, you can separate the video and audio with ffmpeg without transcoding of any kind

something like:

Code: [Select]
ffmpeg -i herp_a_derp_game_recording.avi -c:v copy just_the_video.avi
would copy only the video stream from the recording into a new file.

or

Code: [Select]
ffmpeg -i herp_a_derp_game_recording.avi -c:v copy -c:a copy just_the_video.avi
which would copy the video & 1st audio track into new file.

OR

Code: [Select]
ffmpeg -i herp.avi -map 0:2 -c:a copy microphone_yo.wav
to extract second audio track as wav.

for bit more advanced channel mangling and management: https://trac.ffmpeg.org/wiki/Map
« Last Edit: April 29, 2016, 04:26:48 pm by Malix »

chronosek

  • Soldier
  • **
  • Posts: 54
Re: Adobe Choking on conforming audio, Need solution
« Reply #2 on: April 30, 2016, 12:42:21 am »
Just use other codec, i had problems with lagarith and CS6 too (cause of null frames in avi always had to remux). I recommend UTVideo, it is free, lossless and faster, no problems with longer avi and CS6 for me.
« Last Edit: April 30, 2016, 01:11:18 am by chronosek »
Old Comp Spec: Zalman T4 Mini Tower, Chieftec 750W PS, Gigabyte GA-Z97M-D3H mobo, Intel i7-4790k @4.8GHz proc, Corsair h80i cooler, GoodRam 32GB PC3-12800 ddr3, Gigabyte Geforce 980 GTX 4GB gddr5, 2x 512GB Samsung SSD 840 pro, SoundBlaster ZxR sound, beyerdynamic 990DT pro, Windows 10 Pro x64

ORCACommander

  • Noob
  • *
  • Posts: 7
Re: Adobe Choking on conforming audio, Need solution
« Reply #3 on: April 30, 2016, 02:00:17 am »
I am not currently using Null Frames so that may not be the problem.

So i tried writing up a batch Script for FFMPEG

Code: (Batch) [Select]
for /r %%X in (*.avi) do (
ffmpeg -i "%%X" -map 0:1 -c:a copy "F:\Recordings\Holding Bin\Audio\%%X-Game.wav" -map 0:2 -c:a copy "F:\Recordings\Holding Bin\Audio\%%X-Coms.wav" -map 0:3 -c:a copy "F:\Recordings\Holding Bin\Audio\%%X-MIC.wav" -c:v copy "F:\Recordings\Holding Bin\Video\%%X.avi"
)
pause

And when I run it I am getting an invalid argument error
Not sure but where it is breaking, for everything in the root directory that is of the avi extension do the following: Select Audio stream 1 copy that audio out to specified directory with new name, Same for streams 2 and 3 and then output Video sans audio to specified directory
« Last Edit: April 30, 2016, 04:07:19 am by ORCACommander »

chronosek

  • Soldier
  • **
  • Posts: 54
Re: Adobe Choking on conforming audio, Need solution
« Reply #4 on: April 30, 2016, 03:59:14 am »
It is a well known bug - Dxtory ignores Lagarith null frames setting and creates null frames. CS6 skips that frames and desync causing weird problems.
Btw, you do not need split audio and video, you just need copy all streams inside avi to new file, ffmpeg will fix that null frames, so use -c:v copy -c:a copy on source file (what have video and audio).
« Last Edit: April 30, 2016, 04:19:01 am by chronosek »
Old Comp Spec: Zalman T4 Mini Tower, Chieftec 750W PS, Gigabyte GA-Z97M-D3H mobo, Intel i7-4790k @4.8GHz proc, Corsair h80i cooler, GoodRam 32GB PC3-12800 ddr3, Gigabyte Geforce 980 GTX 4GB gddr5, 2x 512GB Samsung SSD 840 pro, SoundBlaster ZxR sound, beyerdynamic 990DT pro, Windows 10 Pro x64

ORCACommander

  • Noob
  • *
  • Posts: 7
Re: Adobe Choking on conforming audio, Need solution
« Reply #5 on: April 30, 2016, 04:18:54 am »
*sighs* Still why would the video codec be causing Adobe's audio engine to crawl to a stand still. I have had no trouble with the actual video apart from YV12 desaturation.

tried getting rid of the quotation marks and that made it through a new kind of error
Unable to find a suitable output format for 'F:\Recordings\Holding'
F:\Recordings\Holding: Invalid argument

delete the spaces in the directory name and script and it returns the same thing only slightly different

chronosek

  • Soldier
  • **
  • Posts: 54
Re: Adobe Choking on conforming audio, Need solution
« Reply #6 on: April 30, 2016, 04:24:22 am »
Because Adobe trying sync audio and video? If you using normal PCM i can not imagine that audio causing problems, until you have enough space on disk...  Btw spliting audio and video fixing null frames, any remuxing will fix it.
« Last Edit: April 30, 2016, 04:40:36 am by chronosek »
Old Comp Spec: Zalman T4 Mini Tower, Chieftec 750W PS, Gigabyte GA-Z97M-D3H mobo, Intel i7-4790k @4.8GHz proc, Corsair h80i cooler, GoodRam 32GB PC3-12800 ddr3, Gigabyte Geforce 980 GTX 4GB gddr5, 2x 512GB Samsung SSD 840 pro, SoundBlaster ZxR sound, beyerdynamic 990DT pro, Windows 10 Pro x64

ORCACommander

  • Noob
  • *
  • Posts: 7
Re: Adobe Choking on conforming audio, Need solution
« Reply #7 on: April 30, 2016, 04:38:20 am »
audio conforming is done upon import of the asset. Syncing I believe may be done when moving the import to the time line for editing as you can move audio around independently of the video even if they source from the same file. And ya Normal PCM. Some of my old recordings have capture rates higher than the hardware supported so that could of be an issue but it really should only create a lot of empty data. Cache space is not an issue :P And adobe can get through them after a couple of hours, usually with restarting the program several times.

Any Help with the batch script though? If I can just demux the video down to its component parts and avoid the issue it would be great. If i get video issues later on i will consider switching out to a different codec.

chronosek

  • Soldier
  • **
  • Posts: 54
Re: Adobe Choking on conforming audio, Need solution
« Reply #8 on: April 30, 2016, 04:43:21 am »
so if you need restart adobe to get thru then space is the culprit, you need remeber that Media Cache Files for conforming are keept in your local user directory (usual disk C), not project directory
« Last Edit: April 30, 2016, 04:50:47 am by chronosek »
Old Comp Spec: Zalman T4 Mini Tower, Chieftec 750W PS, Gigabyte GA-Z97M-D3H mobo, Intel i7-4790k @4.8GHz proc, Corsair h80i cooler, GoodRam 32GB PC3-12800 ddr3, Gigabyte Geforce 980 GTX 4GB gddr5, 2x 512GB Samsung SSD 840 pro, SoundBlaster ZxR sound, beyerdynamic 990DT pro, Windows 10 Pro x64

ORCACommander

  • Noob
  • *
  • Posts: 7
Re: Adobe Choking on conforming audio, Need solution
« Reply #9 on: April 30, 2016, 04:56:17 am »
Nope I changed all those default settings to a 1.5TB drive that is not C it pretty much does nothing but hold scratch files, media cache and scratch files

chronosek

  • Soldier
  • **
  • Posts: 54
Re: Adobe Choking on conforming audio, Need solution
« Reply #10 on: April 30, 2016, 05:09:43 am »
about script - "%%X" is a whole path and filename with extension (like "F:\Recordings\Holding\input.avi") so you need use only filename, try change your "%%X" with "%%~nX" in ffmpeg line
« Last Edit: April 30, 2016, 05:16:31 am by chronosek »
Old Comp Spec: Zalman T4 Mini Tower, Chieftec 750W PS, Gigabyte GA-Z97M-D3H mobo, Intel i7-4790k @4.8GHz proc, Corsair h80i cooler, GoodRam 32GB PC3-12800 ddr3, Gigabyte Geforce 980 GTX 4GB gddr5, 2x 512GB Samsung SSD 840 pro, SoundBlaster ZxR sound, beyerdynamic 990DT pro, Windows 10 Pro x64

ORCACommander

  • Noob
  • *
  • Posts: 7
Re: Adobe Choking on conforming audio, Need solution
« Reply #11 on: April 30, 2016, 06:49:57 am »
Well I finally got the script working despite a New Error but it seems to be on ffmpeg's end so i will go yell at them for a change.

Only improvements I need to do is make it soft fail on 3 channels if a 3rd channel is absent from the from the source. Currently it will find another file to pull it from :/ and maybe create an output log file

I'll post the script once i sort that out  for all of to enjoy

Thanks for the help

ORCACommander

  • Noob
  • *
  • Posts: 7
Re: Adobe Choking on conforming audio, Need solution
« Reply #12 on: July 06, 2016, 10:41:33 am »
Well I never got it working the way I wanted So here are the two bat files i use now. Make sure you use the one that applies to the situation