Author Topic: DXtory will not sync audio? Help, please!  (Read 733 times)

GalaxseaTurtle

  • Noob
  • *
  • Posts: 2
DXtory will not sync audio? Help, please!
« on: May 22, 2017, 04:24:22 am »
Usually when I record, I am able to use the AVIMux feature in DXtory to sync my game and mic audio into one video file. The last few weeks, it hasn't been working at all. When I go to upload a video into AVIMux it just gives me a blank screen instead of showing the video file. It still "acts" like it's importing a file, but then nothing happens and I can't click "build". I updated the latest version of DXtory, and it worked again for about 2 days, but then it stopped and I haven't been able to sync my audio since. I'm using the same codec I have been using since day 1, Lagarith Losless Codec. Here are a few screenshots of what I'm talking about. http://prntscr.com/fagroj and http://prntscr.com/fags7m  When I click "add", I can still select a video file, and I still get a loading bar, but then the Source Files remains empty and I can't hit Build.

GalaxseaTurtle

  • Noob
  • *
  • Posts: 2
Re: DXtory will not sync audio? Help, please!
« Reply #1 on: May 26, 2017, 11:44:37 am »
Anybody? I'm really struggling to fix this  :-\

Takedown

  • Monster
  • ****
  • Posts: 274
Re: DXtory will not sync audio? Help, please!
« Reply #2 on: May 26, 2017, 03:04:16 pm »
I don't use AVIMux, but you could try renaming or deleting the settings folder for AVIMux in the Dxtory folder
Code: [Select]
C:\Users\<user name>\AppData\Local\Dxtory SoftwareIf that doesn't help, try uninstalling and making sure the entire Dxtory installation folder has been removed and then reinstall.

An alternate way to accomplish mixing your audio tracks is to use ffmpeg.
1.  Grab a static build of ffmpeg for windows ( google it if you need to ) and extract it.
2.  Create a text file and put this inside it
Code: [Select]
set _ffmpeg=C:\ffmpeg\bin\
%_ffmpeg%ffmpeg -fflags +genpts -i "%~dp1%~nx1" -filter_complex "amix=inputs=2" -c:v copy -c:a pcm_s16le "%~dp1%~n1_mixed.avi"
3.  Change the path to ffmpeg ( set _ffmpeg ) to where you have extracted your copy of ffmpeg.  ( It needs to point to the bin folder. )
Depending on what type of PCM used, you may need to change the audio format ( -c:a ) to : pcm_s16le, pcm_s24le, pcm_s32le( for 16,24,32 bit depth )
If needed, set the number of inputs ( amix=inputs=2 ) equal to the number of audio  tracks in the avi file
4.  Once you've made your changes, rename the text file from a .txt to a .bat ( batch file ).
5.  Drag and drop your avi file onto your new batch file and ffmpeg will do the rest.
« Last Edit: May 29, 2017, 10:03:59 am by Takedown »
Using Windows 10 ?  Try the latest version first http://exkode.com/dxtory-downloads-en.html