Author Topic: Gameplay footage audio is really out of sync. How do I fix it?  (Read 4370 times)

aregowe

  • Noob
  • *
  • Posts: 3
Gameplay footage audio is really out of sync. How do I fix it?
« on: September 05, 2014, 09:21:18 pm »
Gameplay footage audio is really out of sync AFTER I take it into Adobe Premiere, and then Export it to H.264 .MP4 format. How do I fix it?

The audio of the recorded .avi is in sync and is fine, but if I take it into Adobe Premiere, do absolutely ZERO edits, and export it to H264 .MP4 format, the audio becomes out of sync.

Basically, as the footage goes on, the audio becomes more and more out of sync for some odd reason. This is VERY apparent during fight scenes & during conversations with NPCs. (Dragon Age 2)

Anyone have any ideas as to what I can do to fix this? I have over 1 hour's worth of footage that this is affecting.

Thank you.

Environment Information:

[Dxtory]
Version: 2.0.128

[System Information]
CPU: AMD FX(tm)-8150 Eight-Core Processor           
CPU Instruction Set: MMX SSE SSE2 SSE3 SSSE3 SSE4.1 SSE4.2 AVX AES EMMX SSE4a XOP FMA4)
OS: Microsoft Windows 7 Ultimate  x64
OSVersion: 6.1.7601
OSLanguage: 1033
ServicePack: Service Pack 1
Memory0: BANK0 4,294,967,296 bytes
Memory1: BANK1 4,294,967,296 bytes
Memory2: BANK2 4,294,967,296 bytes
Memory3: BANK3 4,294,967,296 bytes
TotalMemory: 17,179,869,184 bytes
Total Physical Memory: 17,122,545,664 bytes
Available Physical Memory: 12,870,991,872 bytes
Total Page File: 17,120,636,928 bytes
Available Page File: 11,686,002,688 bytes
Total Virtual Memory: 2,147,352,576 bytes
Available Virtual Memory: 1,739,575,296 bytes
PerformanceCounterFrequency: 14318180 (0xDA7A64)
VideoCard: NVIDIA GeForce GTX 760 Memory: 2,147,483,648 Processor: GeForce GTX 760 DriverVer: 9.18.13.4052 DriverDate: 2014-07-01 20-00-00
Display0: 1600x900 32bits 60Hz
Display1: 1920x1080 32bits 60Hz
SoundDevice: HD Pro Webcam C920 Manufacturer: Logitech
SoundDevice: NVIDIA Virtual Audio Device (Wave Extensible) (WDM) Manufacturer: NVIDIA
SoundDevice: NVIDIA High Definition Audio Manufacturer: NVIDIA
SoundDevice: USB Audio Device Manufacturer: (Generic USB Audio)
SoundDevice: Realtek High Definition Audio Manufacturer: Realtek

[Audio Device]
Realtek Digital Output (Realtek High Definition Audio) - CoreAudioOut
Speakers (2- Razer Megalodon) - CoreAudioOut
Realtek Digital Output(Optical) (Realtek High Definition Audio) - CoreAudioOut
Microphone (2- Razer Megalodon) - CoreAudioIn, Volume 100

[Video Codec]
Dxtory Video Codec FCC:xtor
Cinepak Codec by Radius FCC:cvid
DivX 6.9.2 Codec (8 Logical CPUs) FCC:divx
DivX 6.9.2 YV12 Decoder FCC:yv12
Fraps Video Decompressor FCC:fps1
Huffyuv v2.1.1 - CCESP Patch v0.2.5 FCC:hfyu
Intel IYUV codec FCC:iyuv
Lagarith Lossless Codec FCC:lags
Logitech Video (I420) FCC:i420
Microsoft RLE FCC:mrle
Microsoft Video 1 FCC:msvc
x264vfw - H.264/MPEG-4 AVC codec FCC:x264
Xvid MPEG-4 Codec FCC:xvid

[Audio Codec]
Microsoft IMA ADPCM
Microsoft CCITT G.711
Microsoft GSM 6.10
MS-ADPCM
AC3ACM
MPEG Layer-3 Codec
LAME MP3
PCM
IEEE Float

[Folder]
x H:\Downloads  Speed: 115MB/sec  Free: 479,515,664,384 Total: 1,000,202,039,296 Format: NTFS
SSFolder:

[Movie]
Clipping:
ClipMargin: 0,0,0,0
ClipSize: 0,0
Scaling: Percent 100% 1920x1080
Codec: x264vfw - H.264/MPEG-4 AVC codec, Quality 10000, KeyFrameRate 15, DataRate 0
FrameRate: 30
Output: File AVI
Option: IncludeCursor SyncFPS

[Audio0]
Enabled: True
PushToTalk: False
Device: Speakers (2- Razer Megalodon)
Codec: LAME MP3
Format: Lame MP3 48000 Hz, 320 kbps CBR, Stereo

[Advanced]
Option:
ThreadCount: 4
LimitedFPS: True
FPSLimit: 60
DelayHook: False
DelayHookTime: 5

[LastUsingInformation]
DateTime: 2014/09/04 22:26:52
DeviceType: DX7 DX9 DX11
View0.Type=DX11
View0.CreateFlag=0
View0.FeatureLevel=D3D_FEATURE_LEVEL_11_0
View0.Format=DXGI_FORMAT_R8G8B8A8_UNORM
View0.Size=1920x1080
View0.HWND=0x0002082C
View0.WindowTitle=Dragon Age II - v1.04
View0.ClassName=DragonAge2



« Last Edit: September 05, 2014, 09:28:35 pm by aregowe »

RobiePAX

  • Monster
  • ****
  • Posts: 274
Re: Gameplay footage audio is really out of sync. How do I fix it?
« Reply #1 on: September 06, 2014, 04:32:47 am »
I'm not familiar with this issue. Your LAME MP3 audio codec might be the issue.

Try recording with default PCM Audio Codec and check will you experience the same issue when you export the video through Adobe Premiere.

zerowalker

  • Veteran
  • ***
  • Posts: 132
Re: Gameplay footage audio is really out of sync. How do I fix it?
« Reply #2 on: September 11, 2014, 06:43:07 pm »
Agree, only thing i can think of is Decoding issues.
It's likely that the AVI file has non-zero delay positions, and that may perhaps not be supported. Somehow doubt this though (This would cause a fixed desync, not a gradual).

ZugazAroi

  • Noob
  • *
  • Posts: 2
Re: Gameplay footage audio is really out of sync. How do I fix it?
« Reply #3 on: September 12, 2014, 12:21:36 pm »

I have plenty of material here. Can be used in daily life, not really.

Maestro

  • Noob
  • *
  • Posts: 1
Re: Gameplay footage audio is really out of sync. How do I fix it?
« Reply #4 on: September 15, 2014, 08:22:36 pm »
This could be due to Premiere Pro's problem with handling video files that have a variable FPS rate.
I notice this with h264 Streams inside mp4 containers from nvidia shadowplay too.

The simplest fix is to set dxtory to record at a constant frame rate (30, 25, 100, whatever). This obviously only works if dxtory records at the set frame rate, even if FPS in game fall below that value. (I only just aquired a license and am at work, I will fiddle around with it tonight)
To fix your already recorded files, just run them through handbrake.
Take an h264 preset, set it for a Q level with minimal quality loss and select a constant frame rate.

I had to do this for all the files for an XCOM The Bureau LP. Was a bit of a hassle, but I'm just glad someone found a workaround (which I shamelessly copied). :D
« Last Edit: September 15, 2014, 08:23:29 pm by Maestro »