ExKode Forum

Dxtory => Help & Support => Topic started by: PsiComa on July 24, 2017, 12:26:44 am

Title: Sudden record FPS loss
Post by: PsiComa on July 24, 2017, 12:26:44 am
Hi, I'm puzzled by this and need some help.

I've been using Dxtory for a long time, and it has always worked beautifully. But now, recently, as I try to capture movie from Tabletop Simulator, the rec level is much lower than FPS in game. The resulting movie also stutters. As as always I use my dedicated SSD for capturing, which has a lot of space on it (I've only filled it up and deleted content like 5-10 times, so I don't think it should be messed up just yet.. test says 470 MS/s). I have an i5 processor and GTX TI 980 video card. 

I notice that there pops up a GUI! on the hud when recording, and sometimes STORAGE!.

What does this mean? Is it just windows that have been clogged up and fragmented? Is my SSD drive damaged after all the writing and rewriting? Could it be other reasons why this now suddenly happens?
 Thank you for all help.

Title: Re: Sudden record FPS loss
Post by: Takedown on July 24, 2017, 08:36:02 am
Title: Re: Sudden record FPS loss
Post by: PsiComa on July 24, 2017, 07:47:32 pm
Sorry  :-[  here it comes.

Version: 2.0.142
UID: 83ed402f-3c98-4a4a-a388-7eeb258869e1

[Dxtory Files]
InstallPath: C:\Program Files (x86)\ExKode\Dxtory2.0
amd_ags_x86.dll Size: 94,208 bytes Ver:  SHA1: 07e93edac24c58e411430d61a2f7207d8a7bf078
AppNames.txt Size: 1,091 bytes SHA1: 04c76d2a467c788ad74de95a6d693222601eb82b
AudioStreamSplitter.exe Size: 38,432 bytes Ver: SHA1: 5195bb906a508f9e7175f3c9c7d62c6c76f8217c
AudioStreamSplitter_ja.txt Size: 134 bytes SHA1: 489a5264d73a47edcce7c92edb131cf63e5e5709
AVIFix.exe Size: 72,192 bytes Ver: SHA1: 8743067b975002d014008cfb0db363dfb606c375
AVIFix_ja.txt Size: 288 bytes SHA1: 9cab20780686687b84f604c77c73aaae3fd8126d
AVIMux.exe Size: 166,432 bytes Ver: SHA1: 434d85edc5d4bb77c64ca703f9790062cc87a117
AVIMuxCore.dll Size: 199,200 bytes Ver: SHA1: 53661b27f6f6f9f3e8316dca872fd4b01da93e49
AVIMux_ja.txt Size: 1,701 bytes SHA1: fa240715d701f450bb95377aa8517a252329b619
CryptData.pup Size: 84 bytes SHA1: cf9d724807f965d372da4d168bebd78c5258d6ae
Dxtory.exe Size: 609,488 bytes Ver: SHA1: b8525968062ea3fd9ea766e97a8d58b7fdda45ff
Dxtory64.exe Size: 130,112 bytes Ver: SHA1: 4cce60b896a04515767435c7fd29feefed3c1aac
DxtoryCore.dll Size: 8,295,592 bytes Ver: SHA1: 73d5b7794ac8b0e7abbdeaa10b6106d58d2449d2
DxtoryCore64.dll Size: 8,041,168 bytes Ver: SHA1: 452097b57d594095812ba28a999eed94a7bbd364
DxtoryHK.dll Size: 199,888 bytes Ver: SHA1: 3120931ccc52fbbc15c79e3c992dbe99d69f8536
DxtoryHK64.dll Size: 230,608 bytes Ver: SHA1: 59aaa313d46f273c2c89d6e07e67753c720bf432
DxtoryMM.dll Size: 1,125,952 bytes Ver: SHA1: b0b6fcc47b6b3f326de582975b269d57c2dd0594
DxtoryMM64.dll Size: 1,139,776 bytes Ver: SHA1: 4cc91746487d863e2eea7a572c498c7eddf83817
DxtoryVideo.dll Size: 435,408 bytes Ver: SHA1: 1aadce1a111f7ef840057129a673d6075c1f0edf
DxtoryVideo64.dll Size: 480,464 bytes Ver: SHA1: 36bc4cc08f82a5a605a77f2d58fbfcea1699e18e
DxtoryVideo64_Install.bat Size: 57 bytes SHA1: 5c00dcbc4b631932e7920e7e1bf69e1daf8e26fe
DxtoryVideo64_Uninstall.bat Size: 60 bytes SHA1: 97986d6e7a40eceb84609444ed621c6689526c4d
DxtoryVideoSetting.exe Size: 129,568 bytes Ver: SHA1: ee440e846cfeec2acb4a88f81f589e00c34e825e
DxtoryVideoSetting_ja.txt Size: 1,675 bytes SHA1: e532f36bd5ac6255659d240180637484661f0c83
DxtoryVideo_Install.bat Size: 55 bytes SHA1: 8494f535a15ea10b2d5e0fd62290a88758bf210e
DxtoryVideo_Uninstall.bat Size: 58 bytes SHA1: 6d05923ef8db62f30ee22582f06979f4b2b48a64
DxtoryVulkanLayer.dll Size: 109,776 bytes Ver: SHA1: b8550335c1367d808b2bc64183ecda4ca61927ee
DxtoryVulkanLayer.json Size: 385 bytes SHA1: 2416b04e3895149b4200c1777f470a768519642d
DxtoryVulkanLayer64.dll Size: 132,816 bytes Ver: SHA1: e9c6eaa8d2ad7d684c9525787455d3aca38f6598
DxtoryVulkanLayer64.json Size: 387 bytes SHA1: 13d84a82bda5f98cb6ad6069c13c9ce2304b7d38
Dxtory_ja.txt Size: 19,608 bytes SHA1: 3d0dd54fa0a9ef379f1c663436bfeb799c643963
EULA_en.txt Size: 1,356 bytes SHA1: 340c6b3425ab78d83c6a8bd344b6cc58d152ce8f
EULA_ja.txt Size: 1,814 bytes SHA1: cded0d38ec6a1cb0e86bc264496deaa28082cb51
filelist.txt Size: 279 bytes SHA1: 94b5914435669bca384151d07d728dd504c628b4
filelist64.txt Size: 289 bytes SHA1: 516292e689ee64bc4e19151dadfe6d2cf901b52d
ignore_module_list.txt Size: 1,346 bytes SHA1: 479ca301e9a14d3fc927ca80f6d12481a8644922
InstallVulkanLayer.bat Size: 69 bytes SHA1: 156439c9308c8b5a32d697e1f3c11c2c5199a64b
InstallVulkanLayer64.bat Size: 71 bytes SHA1: 35574f9f2a414e8ebc592a8cec5a83d030b07000
LicReg.dat Size: 13,663 bytes SHA1: e0402e4fb670ca646799839b5604b8f3dd9675e5
LicReg.exe Size: 95,952 bytes Ver: SHA1: 3382997b62809ac29762a6ea62197c6eb4c24094
LicRegNoUI.exe Size: 19,664 bytes Ver: SHA1: cfd4884e884e8fd708874bfcc660f3ea2301693a
LicReg_ja.txt Size: 707 bytes SHA1: 981af64897276c22867952f4972d9c29c6ee35e7
RawCapConv.exe Size: 208,928 bytes Ver: SHA1: 32b6ec5d2f6649df4a47aedc476965433a8bdec4
RawCapConv_ja.txt Size: 1,869 bytes SHA1: 12086976f07abfc8d435abeee6c450c3cb2b07cd
RCStream.dll Size: 164,352 bytes Ver: SHA1: 31266452f142cd7c856384945ffc410b2c9c8be9
readme.txt Size: 1,322 bytes SHA1: f8b7e31de7927309f7f3e03936374837906a94d9
Src16x10_Dest4x3.png Size: 40,081 bytes SHA1: 3b4f6332b8b3129ee351a9c96a9c4ac7f6f7a4cd
Src16x9_Dest4x3.png Size: 40,179 bytes SHA1: fcec824f4e95f7becf65bbabcc1a99c1470b99a1
unins000.dat Size: 23,931 bytes SHA1: 50c850b8d0acd531db425510576db53ccb2b4743
unins000.exe Size: 1,202,896 bytes Ver: 51.1052.0.0 SHA1: d10c3dbe22cec6419f2a81b557432856a7eb91b2
unins000.msg Size: 22,701 bytes SHA1: ab7961d64f8b22503c9c7ca4b335fa539b0278a3
UninstallVulkanLayer.bat Size: 71 bytes SHA1: f54f1fabd821b9e82086eebae8eb89e4e9322f86
UninstallVulkanLayer64.bat Size: 73 bytes SHA1: 3646bdc62ab4d18d3e8bf7e261dbc03ee7d77bfc
UpdateChecker.exe Size: 93,696 bytes Ver: SHA1: 221bd3663f4393b368ebf74d1a892f9379ddbe44
UpdateChecker.ini Size: 238 bytes SHA1: 796da23b4a505bf2ef370dc271d1a80585dff6e2
UpdateChecker_ja.txt Size: 190 bytes SHA1: 969913786a3497f3e448572f7810ee9814314928
UWPHelper.dll Size: 132,304 bytes Ver: SHA1: 5e6de832fad6d5d40bba66e568abc780cd93f9b4
UWPHelper64.dll Size: 159,440 bytes Ver: SHA1: 9ddfab3d06bb0894341ba63a8dab98c83222d38f
DxtoryCodec.dll 64bit Size: 2,606,144 bytes Ver: SHA1: 7ef69696fe270d8bf353ead32bd58681ee61e5fe
DxtoryCodec.dll 32bit Size: 2,499,648 bytes Ver: SHA1: cd610194e3ddceefa04bc0f28a5f2139fee0d615

[System Information]
CPU: Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz
OS: Microsoft Windows 10 Pro x64
OSVersion: 10.0.15063
OSLanguage: 1033
Memory0: BANK 1 8,589,934,592 bytes
Memory1: BANK 3 8,589,934,592 bytes
TotalMemory: 17,179,869,184 bytes
Total Physical Memory: 17,100,734,464 bytes
Available Physical Memory: 14,179,762,176 bytes
Total Page File: 34,280,603,648 bytes
Available Page File: 31,046,320,128 bytes
Total Virtual Memory: 2,147,352,576 bytes
Available Virtual Memory: 1,676,922,880 bytes
PerformanceCounterFrequency: 3421871 (0x3436AF)
VideoCard: NVIDIA GeForce GTX 980 Ti Memory: 4,293,918,720 Processor: GeForce GTX 980 Ti DriverVer: DriverDate: 2017-05-01 02-00-00
Display0: 1920x1080 32bits 60Hz
SoundDevice: NVIDIA High Definition Audio Manufacturer: NVIDIA
SoundDevice: Realtek High Definition Audio Manufacturer: Realtek
SoundDevice: NVIDIA Virtual Audio Device (Wave Extensible) (WDM) Manufacturer: NVIDIA

NVDriver: 382.05 r381_99
GPU0: GeForce GTX 980 Ti Memory: 6144MB MemoryClock: 3600MHz BaseClock: 1190MHz BoostClock: 1291MHz

[Audio Device]
S24D390-4 (NVIDIA High Definition Audio) - CoreAudioOut
Realtek Digital Output(Optical) (Realtek High Definition Audio) - CoreAudioOut
Realtek Digital Output (Realtek High Definition Audio) - CoreAudioOut
S24D390-0 (NVIDIA High Definition Audio) - CoreAudioOut

[Video Codec 64bit]
Intel IYUV codec FCC:iyuv
Intel IYUV codec FCC:i420
Microsoft RLE FCC:mrle
Microsoft Video 1 FCC:msvc
x264vfw - H.264/MPEG-4 AVC codec FCC:x264

[Video Codec 32bit]
Cinepak Codec by Radius FCC:cvid
Intel IYUV codec FCC:i420
Intel IYUV codec FCC:iyuv
Microsoft RLE FCC:mrle
Microsoft Video 1 FCC:msvc
x264vfw - H.264/MPEG-4 AVC codec FCC:x264

[Audio Codec]
Microsoft IMA ADPCM
Microsoft CCITT G.711
Microsoft GSM 6.10
Ogg Vorbis
IEEE Float

[License Information]
License: Registered
Expire: Unlimited
LicVerify: 41501de7ba0c7060bf5cad216158d2e62e65bfa6

[Additional Information]
Dxtory_log.txt: Available Size=64
ErrorLog.txt: Available Size=546

[Global Setting]
OptionFlag: SharedJavaProfile

[Ignore List]


Name: Default

Position: LeftTop
Flag: VidoeFPS RecordFPS RecordState SSNotification  Time Warn
Layout: Vert
Color: Sleep FF00FF00, Active FFFFBC00, Movie  FF00FF00, ScreenShot FF00FF00

x E:  Speed: 470MB/sec  Free: 493,415,788,544 Total: 499,971,518,464 Format: NTFS
  D:  Speed: 293MB/sec  Free: 53,178,146,816 Total: 240,054,693,888 Format: NTFS
SSFolder: E:

MovieCapture: ' (0x0000002B)
PushToTalk: None
ScreenShotSingle: F11 (0x00000057)
ScreenShotRepeat: None
ScreenShotAuto: None
ToggleStatus: None
MovieCaptureFrame: None
ScreenShotCaptureFrame: None

ClipMargin: 0,0,0,0
ClipSize: 0,0
Scaling: Percent 100% 0x0
Codec: Dxtory Video Codec, YUV410
FrameRate: 60
Output: File AVI

Enabled: False
PushToTalk: False
Device: Realtek Digital Output(Optical) (Realtek High Definition Audio)
Codec: PCM
Format: PCM 48000 Hz, 16 bit, Stereo

ClipMargin: 0,0,0,0
ClipSize: 0,0
Scaling: Percent 100% 0x0
HighSpeedLimit: 0
RepeatInterval: 1000
Format: PNG
JpegQuality: 97

ThreadCount: 1
ThreadMask: 0000000000000000
LimitedFPS: False
FPSLimit: 60
DelayHook: False
DelayHookTime: 5


Name: Kholat (64-bit, PCD3D_SM5)
Path: D:\SteamLibrary\steamapps\common\KHOLAT\Kholat\Binaries\Win64\Kholat-Win64-Shipping.exe

DateTime: 2017.07.23 17:00:37
Version: 2.0.142
64bit Process
DeviceType: GL DX9 DX11
View0.WindowTitle=Kholat (64-bit, PCD3D_SM5)


Name: Tabletop Simulator
Path: C:\Program Files (x86)\Steam\steamapps\common\Tabletop Simulator\Tabletop Simulator.exe

DateTime: 2017.07.23 17:33:14
Version: 2.0.142
64bit Process
DeviceType: GL DX9 DX11
View0.WindowTitle=Tabletop Simulator

VerifyHash: cd172c60920e657c1dd64181a5ea5511f9733d39
Title: Re: Sudden record FPS loss
Post by: PsiComa on July 24, 2017, 08:38:10 pm
Did some more testing with other games, and some of them record perfectly fine at 60fps, just as Tabletop Simulator used to do. But now, it gives me the GPU! warning during recording regardless of graphics settings.

Could it just be a compatibility issue with a new version or something?
Title: Re: Sudden record FPS loss
Post by: Takedown on July 25, 2017, 12:20:00 pm
I don't have TTS to test, but try enabling "Multi Device Processing" in Dxtory under the Advanced tab.  If TTS doesn't have a frame rate limiter, you may want to use the one in Dxtory if the fps is above 150.
Title: Re: Sudden record FPS loss
Post by: PsiComa on July 26, 2017, 03:16:27 am
That did it! Enabling Multi Device Processing fixed it!  ;D  It runs smooth like butter, now. Thanks, man. You are the man.

Care to share some light on what it actually does? The short version of the story?
Title: Re: Sudden record FPS loss
Post by: Takedown on July 26, 2017, 03:49:48 pm
Only Exkode knows for sure, but since the tooltip says things like this "Enable async-processing by multi-Device" I think it means Dxtory uses multiple threads to access devices during capture.  I also noticed that on the post called "Dxtory Advanced Option Chart" that Direct3D 9Ex ( or higher ) is required for this feature to work, which means it may use a feature of WDDM video drivers.

If those ideas didn't make since the way I said it, you could also take a look at this article and read the first 2-3 paragraphs.
Title: Re: Sudden record FPS loss
Post by: PsiComa on July 26, 2017, 05:46:41 pm
Thanks once more for the info :)

I also noticed that the recording performance also further improved by disabling the game's V-sync (even though V-sync didn't cause a problem in other games). Worth remembering, just in case.